package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(^|[^_])\bproducts\b([^_]|$)`)
var str = `{% macro products_list(products) %}
{% for product in products %}
productsList
{% endfor %}
{% endmacro %}`
var substitution = "$1.$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}