import Foundation
let pattern = #"(^|[^_])\bproducts\b([^_]|$)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
{% macro products_list(products) %}
{% for product in products %}
productsList
{% endfor %}
{% endmacro %}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1.$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)