using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[1-9]\.\D\W";
string input = @"23434.13431.1234.
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}