using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"192\.168\.2[23]\.[0-9]{1,3}";
string input = @"192.168.22.101
192.168.23.15
192.168.24.123
192.168.22.1";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}