// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"192\.168\.2[23]\.[0-9]{1,3}").unwrap();
let string = "192.168.22.101
192.168.23.15
192.168.24.123
192.168.22.1";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}