Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
([^A-Za-z]|\b)+DR([^A-Za-z]|\b)+
/
g
Input 1
1
New
DR. This is my test string I want to match dr occurences of the case-sensitive word DR. I want all matches where DR is by itself and not part of a word such as DRIFT. I want to find it in the start of and end of a string. DR