$re = '/^(A|B)$/m';
$str = 'ABC
CAB
A
B';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);