import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<p[<>ib]*>([\\w\\s]+)<\\/[\\w]>";
final String string = "<html><head></head><body><p>Aa aa </p><p><b>Aa aa aa </b></p><p>Aa aa aa aa </p><p><i>Aa aa </i></p><p><b><i>B b b </i></b></p><b>Aa aa aa </b></body></html>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}