use strict;
my $str = 'fielda|field b |field\\|with\\|pipe\\|inside';
my $regex = qr/(?<!\\)\|/imp;
my $subst = '\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";