#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[\s\S]*(?=\n{2,})"
Local $sString = "YYYY-MM-DD HH:II:SS Message Log" & @CRLF & _
" Message Log" & @CRLF & _
" Message Log" & @CRLF & _
"" & @CRLF & _
"YYYY-MM-DD HH:II:SS Message Log80s]] "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")