using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[\s\S]*(?=\n{2,})";
string input = @"YYYY-MM-DD HH:II:SS Message Log
Message Log
Message Log
YYYY-MM-DD HH:II:SS Message Log80s]] ";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}