use strict;
my $str = 'website.com
website.com/
http://website.com
https://website.com/
https://website.com/?utm_source=test
https://website.com/product
https://website.com/services/service1
https://website.com/blog
https://website.com/etc.etc.etc';
my $regex = qr/^.*website.com($|\/$|\?.*|\/\?.*)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}