using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(.*ViPNet CSP( \(версия)? 4\.2\)?|\""Крип(р|т)оПро CSP\"" \(?версия (4\.0|3\.9)\)?|Криптотокен (2 )?ЭП.*|Рутокен ЭЦП.*)";
string input = @"""КрипроПро CSP"" (версия 4.0)
""КриптоПро CSP"" (версия 3.6)
""КриптоПро CSP"" (версия 3.9)
""КриптоПро CSP"" (версия 4.0)
""КриптоПро CSP"" версия 3.6
""КриптоПро CSP"" версия 3.9
""КриптоПро CSP"" версия 4.0
Crypto-Pro GOST R 34.10-2001 Cryptographic Service Provider 3.9
Crypto-Pro GOST R 34.10-2001 Cryptographic Service Provider 4.0
JCrypto SDK 2.7.3-R321
ViPNet CSP (версия 3.2)
ViPNet CSP (версия 4.2)
ViPNet CSP 4.0
ViPNet CSP 4.1
ViPNet CSP 4.2
Криптотокен ЭП (0c53000205156035)
Рутокен ЭЦП 2.0 (0c53000216296035)
Криптотокен 2 ЭП (0c53002119206034)
Криптотокен ЭП (4e3900052631304c)
Криптотокен ЭП (4e46001821075047)
Рутокен ЭЦП (4e46001839795047)
Криптотокен ЭП (4e46001951815047)
СКЗИ «Криптотокен» в составе изделия «JaCarta ГОСТ»
Средство криптографической защиты информации (СКЗИ) ViPNet CSP 4.2
Средство криптографической защиты информации ViPNet CSP 4.2
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}