# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(.*ViPNet CSP( \(версия)? 4\.2\)?|\"Крип(р|т)оПро CSP\" \(?версия (4\.0|3\.9)\)?|Криптотокен (2 )?ЭП.*|Рутокен ЭЦП.*)"
test_str = ("\"КрипроПро CSP\" (версия 4.0)\n"
	"\"КриптоПро CSP\" (версия 3.6)\n"
	"\"КриптоПро CSP\" (версия 3.9)\n"
	"\"КриптоПро CSP\" (версия 4.0)\n"
	"\"КриптоПро CSP\" версия 3.6\n"
	"\"КриптоПро CSP\" версия 3.9\n"
	"\"КриптоПро CSP\" версия 4.0\n"
	"Crypto-Pro GOST R 34.10-2001 Cryptographic Service Provider 3.9\n"
	"Crypto-Pro GOST R 34.10-2001 Cryptographic Service Provider 4.0\n"
	"JCrypto SDK 2.7.3-R321\n"
	"ViPNet CSP (версия 3.2)\n"
	"ViPNet CSP (версия 4.2)\n"
	"ViPNet CSP 4.0\n"
	"ViPNet CSP 4.1\n"
	"ViPNet CSP 4.2\n"
	"Криптотокен ЭП (0c53000205156035)\n"
	"Рутокен ЭЦП 2.0 (0c53000216296035)\n"
	"Криптотокен 2 ЭП (0c53002119206034)\n"
	"Криптотокен ЭП (4e3900052631304c)\n"
	"Криптотокен ЭП (4e46001821075047)\n"
	"Рутокен ЭЦП (4e46001839795047)\n"
	"Криптотокен ЭП (4e46001951815047)\n"
	"СКЗИ «Криптотокен» в составе изделия «JaCarta ГОСТ»\n"
	"Средство криптографической защиты информации (СКЗИ) ViPNet CSP 4.2\n"
	"Средство криптографической защиты информации ViPNet CSP 4.2\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
    
    print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
    
    for groupNum in range(0, len(match.groups())):
        groupNum = groupNum + 1
        
        print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.