package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^-?[0-9]\d*(\.\d+)?$`)
var str = `-123.123
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}