# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=(;\d{4}-\d\d-\d\d\n))((?:[^;]++|;)*?)\1"
test_str = ("№;Задача;T;O;P\n"
";2016-01-18\n"
"1. ;task1;03:00;.; \n"
";2016-01-18\n"
"2. ;task2;03:00;.; \n"
";2016-01-18\n"
"3. ;task3;03:00;.; \n"
";2016-01-19\n"
"7. ;33333;03:00;.; \n"
";2016-01-19\n"
"8. ;d;03:00;.; \n"
";2016-01-19\n"
"9. ;00;03:00;.; \n"
";2016-01-20\n"
"21. ;task1;03:00;.; \n"
";2016-01-20\n"
"22. ;task2;03:00;.; \n"
";2016-01-21\n"
"25. ;testtime;03:00;.; \n"
";2016-01-21\n"
"26. ;fgghgfh;23:45;.;, new t.")
subst = "\\2"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.