// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^-?(?:100(?:\.00?)?|\d\d?(?:\.\d\d?)?)$").unwrap();
let string = "-0
-01
0.00
0.1
2
5
33
77
-99
-100.0";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}