$re = '/^-?(\d+|\d{1,3}(?:\,\d{3})+)?(\.\d+)?$/m';
$str = '1234567890
12345678.901
123,456,789.01
123,45678.901
123,456,789..01
123,456,789.
.0123456789
-1234567890
-12345678.901
-123,456,789.01
-123,45678.901
123,456,789..01
-123,456,789.
-.0123456789';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);