$re = '/^[a-zA-Z_]\w*(\.[a-zA-Z_]\w*)*$/m';
$str = 'Parent.Property
Name
_P.Age
_Parent._Name
p.Office_Address
_
@Bool
9Type
_Parent.@static
@class._
@pou8_9iu.@
@
_Parent.9
7';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);