$re = '/(?<![\>https?:\/\/|href=\"\'])(?<http>(https?:[\/][\/]|www\.)([a-zA-Z0-9\/.&?=-~-]+)*)/';
$str = 'http://www.webmotors.com.br/comprar/audi/a6/3-0-limousine-v6-30v-gasolina-4p-multitronic/4-portas/2002/13395497';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);