$re = '/^[a-zA-Z0-9ČŠŽĐ\'](?:[A-Z0-9 ČŠŽĐ\']{0,31}[A-Z0-9ČŠŽĐ\'])?$/i';
$str = 'Šolski center Nova Gorica';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);