package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:'([^'\\]*(?:\\.[^'\\]*)*)'|([^,]+))`)
var str = `'ei-1395529080',0,0,1,1,'Name','email@domain.com','Sentence with \'escaped apostrophes\', which \'should\' be on one line!','no','','','yes','6.50',NULL`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}