import Foundation
let pattern = #"([^:])(\/{2,})"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<a href="//google.com"><img src="http://www.ebeyonds.com/sec.png"></a>
<a href="https://host.org"><img src="http://www.ebeyonds.com/sec.png"></a>
<a href="http://www.ebeyonds.com/www.abc.com"><img src="http://www.ebeyonds.com//www.abc.com"></a>
<a href="mailto:chairman@edb.tradenetsl.lk"><img src="http://www.ebeyonds.com//www.abc.com"></a>
<link href="http://www.ebeyonds.com//a//styles.css" rel="alternate stylesheet" type="text/css" />
<script type="text/javascript" src="http://www.ebey
<a href="//google.com"><img src="sec.png"></a>
<a href="https://host.org"><img src="sec.png"></a>
<a href="www.abc.com"><img src="/www.abc.com"></a>
<a href="mailto:chairman@edb.tradenetsl.lk"><img src="/www.abc.com"></a>
<link href="/a//styles.css" rel="alternate stylesheet" type="text/css" />
<script type="text/javascript" src="./style.js"></script>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}