import re
regex = re.compile(r"^[a-z0-9]+(?!.*(?:\+{2,}|\-{2,}|\.{2,}))(?:[\.+\-]{0,1}[a-z0-9])*@gmail\.com$", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("niceandsimple@gmail.com\n"
"very.common@gmail.com\n"
"disposable.style.email.with+symbol@gmail.com\n"
"other.email-with-dash@gmail.com\n"
"invalid--email@gmail.com\n"
"invalid++email@gmail.com\n"
"invalid..email@gmail.com\n"
"-invalid-email@gmail.com\n"
"invalid--email-@gmail.com")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")