re = /^[a-z0-9]+(?!.*(?:\+{2,}|\-{2,}|\.{2,}))(?:[\.+\-]{0,1}[a-z0-9])*@gmail\.com$/mi
str = 'niceandsimple@gmail.com
very.common@gmail.com
disposable.style.email.with+symbol@gmail.com
other.email-with-dash@gmail.com
invalid--email@gmail.com
invalid++email@gmail.com
invalid..email@gmail.com
-invalid-email@gmail.com
invalid--email-@gmail.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end