re = /(?=({(?>[^{}]|(?1))+}))/
str = 'Hello World {foo{bar}} World Hello!
{first{second{third}second}first}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end