# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\w+/\w{32}\.html"
test_str = ("history/2c0b65635b3ac68a4d53b89521216d26.html\n"
"history/2c0b65635b3ac68a4d53b89521216d26_0.html\n"
"marketing/3c0a65635b2bc68b5c43b88421306c37.html\n"
"marketing/3c0a65635b2bc68b5c43b88421306c37_0.html")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.