#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "%a+"
Local $sString = "HTTP/1.1 200 OK" & @CRLF & _
"Cache-Control: private" & @CRLF & _
"Content-Type: text/plain; charset=utf-8" & @CRLF & _
"X-AspNet-Version: 4.0.30319" & @CRLF & _
"Date: Sat, 13 Feb 2016 19:33:11 GMT" & @CRLF & _
"Content-Length: 6" & @CRLF & _
"" & @CRLF & _
"|on||30|"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")