$re = '/%a+/';
$str = 'HTTP/1.1 200 OK
Cache-Control: private
Content-Type: text/plain; charset=utf-8
X-AspNet-Version: 4.0.30319
Date: Sat, 13 Feb 2016 19:33:11 GMT
Content-Length: 6
|on||30|';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);