$re = '/(\w+?)_(\d+)(?:\.|$)/i';
$str = 'group_12.label:sub_1.field_23.label+long_field.label:another.label+long_field_345';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);