#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)(?(DEFINE)(?<proto>(?:https?:)?\/\/)(?<port>:[0-9]{2,5})(?<tld>(?:a(?:[cd]|e(?:ro)?|[fgil-oqr]|s(?:ia)?|[tuwxz])|b(?:[abd-h]|iz?|[jl-oq-tvwyz])|c(?:at?|[cdf-ik-n]|o(?:m|op)?|[ru-z])|d[ejkmoz]|e[ceghr-u]|f[i-kmor]|g[abd-il-np-uwy]|h[kmnrtu]|i(?:[delm]|n(?:fo|t)?|[oq-t])|j(?:[em]|o(?:bs)?|p)|k[eg-imnprwyz]|l[a-cikr-vy]|m(?:[ac-hk]|lc?|[mn]|o(?:bi)?|[p-t]|u(?:seum)?|[v-z])|n(?:a(?:me)?|c|et?|[fgilopruz])|o(?:m|rg)|p(?:[ae-hk-n]|ost|ro?|[stwy])|qa|r[eosuw]|s(?:[a-eg-or]|t(?:udio)?|[uvx-z])|t(?:[cd]|el|[f-hj-p]|r(?:avel)?|[tvwz])|u[agkmsyz]|v[aceginu]|w[fs]|y[et]|z[amw]))(?<path>(\/(?:[a-z0-9+%-]\.?)+)*\/?)(?<query>\?[a-z+&$_.-][a-z0-9;:@&%=+\/.-]*)(?<hash>\#[a-z_.-][a-z0-9+$%_.-]*)(?<subdomain>[a-z0-9\-\.]+\.)(?<yt_domain>(?:www\.)?(?:youtube\.com|youtu\.be)\/)(?<yt_hash>(?:[\w-]{10,12})+)(?<yt_video>(?&proto)?(?&yt_domain)+(?:watch)?(?:\/embed\/|\?v=)+(?&yt_hash)+))((?&yt_video).*(*SKIP)(*FAIL)|(?&proto)?(?&subdomain)(?&tld)(?&port)?(?&path)?(?&query)?(?&hash)?)"
Local $sString = "Lines which should be partially or fully matched:" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"http:www.google.com/" & @CRLF & _
" http//www.google.com/" & @CRLF & _
"http://www.google.com/" & @CRLF & _
" ://www.google.com/" & @CRLF & _
" www.google.com/" & @CRLF & _
" www.google.com:8000" & @CRLF & _
" www.google.com/?key=value" & @CRLF & _
" github.io" & @CRLF & _
" www.google.com/abc/def/ijk#123" & @CRLF & _
" www.google.com/abc/def/ijk?v=123123123" & @CRLF & _
" www.google.com/abc/def/watch?v=1231231231" & @CRLF & _
"https://www.youtube.com/channel/UCgeu2xe0XRscaKyvBt3WgmQ" & @CRLF & _
"http://www.google.com/?key=value" & @CRLF & _
"http://www.youtube.com/ " & @CRLF & _
"" & @CRLF & _
"However, it should skip (do not match lines) which contain youtube video ID):" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"http://www.youtube.com/watch?v=B5Gj78s6H7w&feature=youtu.be" & @CRLF & _
"https://www.youtube.com/embed/y19EaW2X7ac" & @CRLF & _
" music.youtube.com/embed/y19EaW2X7ac" & @CRLF & _
"https://www.youtube.com/watch?v=B5Gj78s6H7w&feature=youtu.be" & @CRLF & _
"https://www.youtube.com/watch?feature=youtu.be&v=B5Gj78s6H7w" & @CRLF & _
"https://www.youtu.be/B5Gj78s6H7w&feature=youtu.be" & @CRLF & _
"https://www.youtu.be/B5Gj78s6H7w" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")