# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?i)(?(DEFINE)(?<proto>(?:https?:)?\/\/)(?<port>:[0-9]{2,5})(?<tld>(?:a(?:[cd]|e(?:ro)?|[fgil-oqr]|s(?:ia)?|[tuwxz])|b(?:[abd-h]|iz?|[jl-oq-tvwyz])|c(?:at?|[cdf-ik-n]|o(?:m|op)?|[ru-z])|d[ejkmoz]|e[ceghr-u]|f[i-kmor]|g[abd-il-np-uwy]|h[kmnrtu]|i(?:[delm]|n(?:fo|t)?|[oq-t])|j(?:[em]|o(?:bs)?|p)|k[eg-imnprwyz]|l[a-cikr-vy]|m(?:[ac-hk]|lc?|[mn]|o(?:bi)?|[p-t]|u(?:seum)?|[v-z])|n(?:a(?:me)?|c|et?|[fgilopruz])|o(?:m|rg)|p(?:[ae-hk-n]|ost|ro?|[stwy])|qa|r[eosuw]|s(?:[a-eg-or]|t(?:udio)?|[uvx-z])|t(?:[cd]|el|[f-hj-p]|r(?:avel)?|[tvwz])|u[agkmsyz]|v[aceginu]|w[fs]|y[et]|z[amw]))(?<path>(\/(?:[a-z0-9+%-]\.?)+)*\/?)(?<query>\?[a-z+&$_.-][a-z0-9;:@&%=+\/.-]*)(?<hash>\#[a-z_.-][a-z0-9+$%_.-]*)(?<subdomain>[a-z0-9\-\.]+\.)(?<yt_domain>(?:www\.)?(?:youtube\.com|youtu\.be)\/)(?<yt_hash>(?:[\w-]{10,12})+)(?<yt_video>(?&proto)?(?&yt_domain)+(?:watch)?(?:\/embed\/|\?v=)+(?&yt_hash)+))((?&yt_video).*(*SKIP)(*FAIL)|(?&proto)?(?&subdomain)(?&tld)(?&port)?(?&path)?(?&query)?(?&hash)?)"
test_str = ("Lines which should be partially or fully matched:\n\n\n"
"http:www.google.com/\n"
" http//www.google.com/\n"
"http://www.google.com/\n"
" ://www.google.com/\n"
" www.google.com/\n"
" www.google.com:8000\n"
" www.google.com/?key=value\n"
" github.io\n"
" www.google.com/abc/def/ijk#123\n"
" www.google.com/abc/def/ijk?v=123123123\n"
" www.google.com/abc/def/watch?v=1231231231\n"
"https://www.youtube.com/channel/UCgeu2xe0XRscaKyvBt3WgmQ\n"
"http://www.google.com/?key=value\n"
"http://www.youtube.com/ \n\n"
"However, it should skip (do not match lines) which contain youtube video ID):\n\n\n"
"http://www.youtube.com/watch?v=B5Gj78s6H7w&feature=youtu.be\n"
"https://www.youtube.com/embed/y19EaW2X7ac\n"
" music.youtube.com/embed/y19EaW2X7ac\n"
"https://www.youtube.com/watch?v=B5Gj78s6H7w&feature=youtu.be\n"
"https://www.youtube.com/watch?feature=youtu.be&v=B5Gj78s6H7w\n"
"https://www.youtu.be/B5Gj78s6H7w&feature=youtu.be\n"
"https://www.youtu.be/B5Gj78s6H7w\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.