import Foundation
let pattern = #",(?=[^(]*\))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Lorem ipsum dolor sit amet, consetetur sadipscing (elitr, sed diam nonumy eirmod tempor invidunt, ut labore, et dolore magna aliquyam erat), (sed diam) voluptua. (At, vero) eos et accusam et justo duo dolores et ea rebum. Stet clita kasd gubergren, no sea takimata sanctus est Lorem ipsum dolor sit amet."#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"+"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)