import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:[a-zA-Z0-9]+[-]*[a-zA-Z0-9]+)(?:[.][a-zA-Z0-9]+[-]*[a-zA-Z0-9]+)+$";
final String string = "www.google.com\n"
+ "google.com\n"
+ "goo gle.com\n"
+ "google.com \n"
+ " google.com\n"
+ "-www.google.com\n"
+ "www-.google.com\n"
+ "w-1.google.com\n"
+ "www.goo-gle.com\n"
+ "goo-gle.com\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}