re = /^(?:[a-zA-Z0-9]+[-]*[a-zA-Z0-9]+)(?:[.][a-zA-Z0-9]+[-]*[a-zA-Z0-9]+)+$/m
str = 'www.google.com
google.com
goo gle.com
google.com
google.com
-www.google.com
www-.google.com
w-1.google.com
www.goo-gle.com
goo-gle.com
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end