const regex = /(?:https?:\/{2})?w{0,3}\.?[\.\d\w-]+\/?([-_\d\w]+):([-_\d\w]+)/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:https?:\\\/{2})?w{0,3}\\.?[\\.\\d\\w-]+\\\/?([-_\\d\\w]+):([-_\\d\\w]+)', 'i')
const str = `http://www.any-domain.com/section:VALUE`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}