# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(.*)<p[^>]*>.*<\/p>\R?/$1/ms;t' <<< "<p align=\"justify\">First paragraph</p>
<p>Second paragraph</p>
<p>Third paragraph</p>
<div class=\"item\">
<p>Some paragraph here</p>
<p><strong><u>Specs</u>:</strong><br /><br /><strong>Weight:</strong> 10kg<br /><br /><strong>LxWxH:</strong> 5mx1mx40cm</p
<p align=\"justify\">second last para</p>
<p align=\"justify\">This is the paragraph I am trying to remove with regex.</p>
</div>"