#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!.*(?:\.(?:exe|sh|js|bat)(?:\.|$))).*\.(?:pdf|xls)$"
Local $sString = "file.pdf" & @CRLF & _
"file.xls" & @CRLF & _
"i want to exclude" & @CRLF & _
"file.sh" & @CRLF & _
"file.exe" & @CRLF & _
"file.js" & @CRLF & _
" or " & @CRLF & _
"file.bat" & @CRLF & _
"filename.exe.pdf" & @CRLF & _
"" & @CRLF & _
"screenshot.pdf" & @CRLF & _
"nexe.csv"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")