const regex = /(in)(?=\s*\d+)|' time/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(in)(?=\\s*\\d+)|\' time', 'g')
const str = `2014/12/04 Test in 1 day' time 0 weeks
2014/12/07 Amazon Prime Ends in 95 days | 13 weeks
2014/12/24 Christmas in China in 112 days | 16 weeks`;
const subst = `|`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);