package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:^[^\(\)]*?\()?(?:(.*?\)),|(.*?)\)$)`)
var str = `func1(func2(arg1, arg2),func3(func4(arg3)),arg4)`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}