use strict;
my $str = '101
1000
500
200
99
100
102
999
020
';
my $regex = qr/(?!^100$)^[1-9][0-9][0-9]$/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";