$re = '/(?:start:(?=\w+(?:-\w+){2,9}:end)|(?!^)\G-)(\w+)/';
$str = '-Should-not-match
Some text here and start:test-test-lorem-ipsum-sir-doloret-etc-something:end another something start:SIR-doloret-something:endand this is a non-match: start:SOMmething-blabla:end because hasn\'t got enough groups.
This also start:REST-doloret-etc-something:end but not this: start:XXYY-lorem-ipsum-sir-doloret-etc-something-8-nine-ten-eleven:end because i
t\'s too long. start:XXYY-lorem-ipsum-sir-doloret-etc-something-8-nine-ten:end just there, and also start:XXYY-lorem-ipsum:end-garbage
This shouldn-t match also start:nothing:end! start:nothing-next:end
Test start:Something-nine-ten-eleven:end-bla-blastart:REST-doloret-etc-something:end---';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);