use strict;
my $str = '30.08.2016 08:00:00.004 *ERROR* [pool-7-thread-5] com.day.cq.reporting.impl.snapshots.SnapshotServiceImpl Error accessing repository during creation of report snapshot data
javax.jcr.LoginException: Cannot derive user name for bundle com.day.cq.cq-reporting [313] and sub service null
';
my $regex = qr/(\d{2}.\d{2}.\d{4}).*?(\d{2}:\d{2}:\d{2}).\d{0,3}.*?\*(ERROR)\*.*?(\[.*?\]).(.*?\..*?)\s+?(.+)\n/sp;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}