# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^style="url\((['"])?(?:\.\.)?(?<url>[^'"]+)\1?\)"/style="url($1http:\/\/mysite.com$2$1)"/gm;t' <<< "style=\"url(/test.png)\"
style=\"url(\"/test.png\")\"
style=\"url('/test.png')\"
style=\"url(../test.png)\"
style=\"url(\"../test.png\")\"
style=\"url('../test.png')\""