use strict;
my $str = 'style="url(/test.png)"
style="url("/test.png")"
style="url(\'/test.png\')"
style="url(../test.png)"
style="url("../test.png")"
style="url(\'../test.png\')"';
my $regex = qr/^style="url\((['"])?(?:\.\.)?(?<url>[^'"]+)\1?\)"/mp;
my $subst = 'style="url($1http://mysite.com$2$1)"';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";