// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[1-9][0-9][0-9]$|^[1][0-9][0-9][0-9]$").unwrap();
let string = "99
100
123
200
500
999
1000
1234
1500
1999
2000
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}