#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(\w)\1*"
Local $sString = "aaabbbbcccaacddd"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)