#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mU)id="(.*)""
Local $sString = " <property id="leftLogoURL" labelText="Override Left Logo URL" dataType="string" defaultValue=""></property>" & @CRLF & _
" <property id="rightLogoURL" labelText="Override Right Logo URL" dataType="string" defaultValue=""></property>" & @CRLF & _
"" & @CRLF & _
" <property id="title" labelText="Override Group Title" dataType="string" defaultValue=""></property>" & @CRLF & _
"" & @CRLF & _
" <property id="description" labelText="Override Group Description" dataType="string" rows="2" defaultValue=""></property>" & @CRLF & _
"" & @CRLF & _
" <property id="underDescription" labelText="HTML Under Description" dataType="html" rows="5" defaultValue=""></property>" & @CRLF & _
"" & @CRLF & _
" <property id="button1state" labelText="Button 1 Display Mode" dataType="string" defaultValue="Standard">" & @CRLF & _
" <propertyValue value="Automatic" labelText="Automatic" propertiesToHide="button1label,button1url" propertiesToShow="" />" & @CRLF & _
" <propertyValue value="Overriden" labelText="Overriden" propertiesToHide="" propertiesToShow="button1label,button1url" />" & @CRLF & _
" <propertyValue value="Disabled" labelText="Disabled" propertiesToHide="button1label,button1url" propertiesToShow="" />" & @CRLF & _
" </property>" & @CRLF & _
" <property id="button1label" labelText="Button 1 Label" dataType="string" defaultValue=""></property>" & @CRLF & _
" <property id="button1url" labelText="Button 1 URL" dataType="string" defaultValue=""></property>" & @CRLF & _
"" & @CRLF & _
" <property id="button2state" labelText="Button 2 Display Mode" dataType="string" defaultValue="Standard">" & @CRLF & _
" <propertyValue value="Automatic" labelText="Automatic" propertiesToHide="button2label,button2url" propertiesToShow="" />" & @CRLF & _
" <propertyValue value="Overriden" labelText="Overriden" propertiesToHide="" propertiesToShow="button2label,button2url" />" & @CRLF & _
" <propertyValue value="Disabled" labelText="Disabled" propertiesToHide="button2label,button2url" propertiesToShow="" />" & @CRLF & _
" </property>" & @CRLF & _
" <property id="button2label" labelText="Button 2 Label" dataType="string" defaultValue=""></property>" & @CRLF & _
" <property id="button2url" labelText="Button 2 URL" dataType="string" defaultValue=""></property>" & @CRLF & _
"" & @CRLF & _
" <property id="button3state" labelText="Button 3 Display Mode" dataType="string" defaultValue="Standard">" & @CRLF & _
" <propertyValue value="Automatic" labelText="Automatic" propertiesToHide="button3label,button3url" propertiesToShow="" />" & @CRLF & _
" <propertyValue value="Overriden" labelText="Overriden" propertiesToHide="" propertiesToShow="button3label,button3url" />" & @CRLF & _
" <propertyValue value="Disabled" labelText="Disabled" propertiesToHide="button3label,button3url" propertiesToShow="" />" & @CRLF & _
" </property>" & @CRLF & _
" <property id="button3label" labelText="Button 3 Label" dataType="string" defaultValue=""></property>" & @CRLF & _
" <property id="button3url" labelText="Button 3 URL" dataType="string" defaultValue=""></property>" & @CRLF & _
" "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")