package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\w+):\/\/(\w+):(\d+)\?(.*$)`)
var str = `GET://HOSTNAME1234:14159?arg0=C:\sim.zip&arg1=C:\bif.txt&arg2=C:\wpt.txt`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}