// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\w+):\/\/(\w+):(\d+)\?(.*$)").unwrap();
let string = "GET://HOSTNAME1234:14159?arg0=C:\\sim.zip&arg1=C:\\bif.txt&arg2=C:\\wpt.txt";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}